libadwaita
I need ideas.
Thinking what to name that view for utility panes from my last thread.
So currently I have AdwDualPaneView for sidebars that turn into browsing when folded.
The line between utility panes and sidebars in HIG is rather thin:
- they are used differently
- sidebars use split header bars, utility panes don't
- they handle adaptivity different
The first 2 points don't concern API and so the 2 widgets are basically identical when unfolded. On top of a lot of people using them for actual sidebars - for example, AdwDualPaneView only allows sidebars on the left because otherwise the folded state doesn't make sense. The utility pane view can put the sidebar on either side, and e.g. Emblem would use it there just because of that. And, similarly, I can see quite a lot of apps use it for more than strictly the HIG definition of utility panes.
And so I don't think it makes sense to call it anything related to utility panes.
Before the name "utility pane" appeared, we were using the name "transient sidebar", and I find it describes what this widget is more accurately.
At the same time, the name "dual pane view" stops making sense when we have a second widget that's also 2 pane. In HIG terms it's a sidebar. Obviously this widget is not just sidebar but sidebar+content, but "sidebar view" could still work.
So I'm leaning towards the following names:
- AdwNavigationSidebarView - becomes browsing when folded
- AdwTransientSidebarView - becomes overlay when folded
But they are long and unwieldy, that's not great. Any ideas for something shorter but still clear/making sense? So not like leaflet/flap where it's just random words, but also not as long.
Other ideas:
- Android calls the latter kind "navigation drawers", but uses them too differently from us
- UIKit and SwiftUI call the first kind UISplitViewController and NavigationSplitView. But "split view" can refer to both
- A lot of web frameworks seem to be calling the latter kind overlay sidebars
libadwaita
@nsrosenqvist looking it up, it doesn't look like a sidebar.
In libadwaita case it's these sidebars.
libadwaita
@alexm here's a description of it: https://developer.mozilla.org/en-US/docs/Web/HTML/Element/aside
libadwaita
@nsrosenqvist that was where I looked, yes. :)
But what’s in my screenshot doesn’t really look like a sidebar?..
libadwaita
@nsrosenqvist hm, ok. I'm already having a hard time understanding it tho, so I don't think it works.
libadwaita
@alexm @nsrosenqvist well in HTML5, these semantic elements got introduced. these are things like "aside", "article", "nav", "header" etc...
they don't really do anything special (expect maybe a little bit of accessibility) but semantically they help, because you don't have to write a shit load of div's
libadwaita
@vixalientoots @nsrosenqvist I mean that's fair enough, it just seems too text-specific, so doesn't really work for widgets.
libadwaita
@alexm @nsrosenqvist again, it's just for practice. they don't come with any style at all, and you have to style them manually (give them the "aside" look you want), html doesn't care lol. maybe you can name it sidebar then
libadwaita
@vixalientoots @nsrosenqvist I mean my original toot wasn't about html.
libadwaita
@dimanech that's what I tried to do with the name "dual pane view", but the problem is that hig already has the term "utility pane", which is a subset of what one of those widgets is for.
And I mean how would you differentiate the "becomes browsing when folded" or "becomes an overlay when folded" with that? Names like split pane or dual pane can mean either.
I see windows uses "navigation pane" for the vertical icon strip at least.
libadwaita
@alexm Maybe it sound terrible from you perspective, since I do not know the domain so deep and do not have same context as you do. One way to make name more convenient could be using old common, well-known standard view (wide view) name + responsive (narrow) view changes. Ex: adwUtilityPaneOver / adwUtilityPanePush (or slide); dualPaneOverlayed / dualPaneSlided; splitPaneOver / splitPanePush etc.
libadwaita
@dimanech I mean it doesn't sound terrible, but also doesn't work:
- Utility pane is a specific thing from hig and it's a small subset of what these widgets are for, so that out is out. Plus, utility pane is only that pane, while the widget contains both panes, hence View in my names
- Over/slide/push - these sound like they are about the animation. Meanwhile in these widgets the animation is "over" in both cases, it's this instead: https://neurodifferent.me/@alexm/109988409384750736
And well, in case of push/over might as well use sidebar instead of split pane as it's shorter ^^
Another name from GTK is GtkPaned, but that's a bit different: Paned's main feature is a resizable separator which we don't have here.